settingsLogin | Registersettings
Es tu primera visita? Te invitamos a visitar nuestra sección de preguntas frecuentes FAQ!
x
Show Menu

Problemas de relacion de confianza entre servidores

0 votos
Hola

Tengo problemas de realcion de confianza entre el servidor principal ( servidor windows 2008 server con active directory ) y un servidor virtual con window 2008 server ( este servidor esta unido al servidor principal como si fuese un simple windows 7 ).

Tengo creada una relacion de confianza entre los dos windows server .

Mi problema es que ahora a la hora de entrar en el segundo servidor me dice que no puedo entrar ya que no existe una realcion de confianza entre ambos y claro el usuario y la contraseña no la reconoce.

Claro los equipos que si estan unidaos al dominio no son capaces ni de entrar a ver las carpetas compartidas ni de hacer un simple terminal server ya que las contraseña no las reconoce.

Abria alguna manera de poder recomponer esa relacion de confianza entre ambos sin tener que volver a unir el segundo server al dominio. Esto me supondria perder la configuracion creada con ese usuario ( el perfil del usuario ).

A ver si me podeis hechar una mano.

 

Gracias
preguntado por cdistri (121 puntos)   Mar 25, 2014
Hola cdistri, si entre de las respuestas que recibes, has encontrado la solución a tu problema o duda, debes seleccionarla como mejor respuesta, de esta manera el usuario que te ayudó, recibe los puntos por ayudarte

4 Respuestas

0 votos
hola colega, no es necesario que generes una relación de confianza entre los servidores, a menos que ambos pertenezcan a dominios diferentes. Si has unido el segundo servidor a tu dominio principal, vos debes hacer es agregar los usuarios del dominio al grupo de terminal server en el segundo servidor. las carpetas que compartes también usted deberá agregar los usuarios del domain principal, asi podrán abrir terminal server y accesos a recursos compartidos.

 

comentanos si te sirvió nuestra ayuda

 

Serba
respondido por serba_tech (279 puntos)   Mar 25, 2014
0 votos
Hola

El usuario es el usuario de administrador del controlador del dominio, ya que cuando lo uni lo unicon ese usuario y contraseña.

Ahora pulso control+alt+sup para poner la contraseña y una vez que pongo el usuario administrador con la contraseña me salta el erro de que no hay ninguna relacion de confianza entre el pc y el controlador de dominio.

La sensacion que me da es que se ha desvinculado del controlador de dominio. Tendria que volverlos a unir, el problema que el perfil de usuario desaparece con todas las configuraciones que tenia.

Ademas tengo que entrar en el equipo el cual no me deja.

A ver ai a alguine se le ocurre algo mas.

 

Gracias
respondido por cdistri (121 puntos)   Mar 25, 2014
debes iniciar sesión como administrator local de ese servidor secundario, para eso, ingresa asi:
localhost\administrator y ponés la contraseña
si ha perdido la relación de confianza fíjate en este documento de Microsoft, en la parte de la solución http://support.microsoft.com/kb/162797

comenta y marcar si ha servidor la respuesta

SErba
Hola
Esto es exactamente lo que me ocurre. Lo unico es que ami me sale el error Error en la relación de confianza entre esta estación de trabajo y el dominio principal al poner el nombre de usuario y contraseña.
Pero es lo que me esta ocurriendo y como pensaba hay que volver a unirlo al dominio principal.
Mi pregunta es si hubiera un comando o algo parecido el cual se ejecute en el servidor para renovas el sid sin tener que volver a unirlo al dominio principal y no perder la configuracion del perfil.

Gracias
0 votos
Hola

Mirando por google he conseguido encontrar lo siguiente:

Cuando falla el canal de seguridad hay que restablecerlo.

NO eliminar el equipo del dominio y unirlo de nuevo, con esta práctica eliminamos la cuenta de equipo totalmente, por consiguiente perdemos el SID del equipo y su pertenencia a grupos, aunque después lo unamos con el nombre que tenía anteriormente.

    Restablecer la cuenta desde Usuarios y Equipos de A.D. (desde DC): Click con el 2º sobre el equipo à Restablecer la cuenta à confirmamos la operación. El puesto que tenía problemas debe reiniciarse y unirse de nuevo al dominio.
    Restablecer la cuenta con NETDOM (desde el DC):

netdom   reset   Equipo_4   /Domain:contoso   /Server:Server01

/UserO:Administrador   /Password:*

   * Equipo_4: Es el puesto que tiene dificultades de logeo con el dominio.

                 * Domain : Especifica el dominio con el que queremos establecer la conexión.

                 * Server: Nombre del controlador de dominio.

                 * UserO: Cuenta usuario local que usaremos en el puesto que va a restablecerse.

                 * PasswordO: Contraseña. Un [*] indica que debe solicitarse la contraseña.

Con este método no hay que reiniciar el puesto ni volverlo a unir al dominio.

    Restablecer la cuenta con Nltest (desde el puesto):

nltest:Server01/sc_rest:contoso/Server01

    sc_rest: Restablecer canal seguro.

Con este método no hay que reiniciar el puesto ni volverlo a unir al dominio.

Nltest y Netdom establecen un canal seguro sin necesidad de reiniciar el equipo, por este motivo hay que probar primero con estos comandos. En caso de que fallen utilizaremos el comando Restablecer cuenta, desde el complemento de Equipos y usuarios de A.D.

Es de un compañero del foro.

Voy a probar a ver si funciona.

 

Gracias
respondido por cdistri (121 puntos)   Mar 26, 2014
Si, existe esa posibilidad para no tener que volver a unirlo al dominio, lo que debes hacer para ingresar localmente es poner la contraseña de administrator "local" , no use la contraseña de administrator del dominio.

suerte y comenta como te fue con netdom
0 votos
Hola

Ya he logrado poder entrar como local, haciendo cambios en la contraseña local de windows 2008 server ya que no la conocia.

He seguido los pasos anteriormente dichos pero no conseguia ningun resultado.

Al final me he decidido y lo he sacado del dominio y lo he vuelto ha unir.

Mi suerte o casualidad es que no ha perdido la configuracion. Se ha quedado tal cual estaba.

Milagro.

Todo lo anterio dicho no me ha servido nada mas que para perder el tiempo.

LA SOLUCION es volver a unir el equipo al dominio.

 

Gracias por todo
respondido por cdistri (121 puntos)   Mar 26, 2014
Si, en la KB de Microsoft indicaba que esa era la solución inicial
...